Status
Back
Maintenance
GitLab update
Completed 11 Mar at 11:45am CET.
Affected services
GitLab
Completed
Maintenance completed
Posted 11 Mar at 11:45am CET.
Started
Updating GitLab to the newest version
Posted 11 Mar at 11:29am CET.